Your Classic Car Community and Marketplace
MyOldRide Account | OldRide Store | Support | Site Map   
OldRide HomeClassic Cars and Trucks For SaleClassic Car and Truck Parts For SaleSell on OldRideOldRide AnswersRusty RidesCar Show ListingsCar Club ListingsResearch Library 
 
OldRide Answers Home
Using OldRide Answers
Ask a Question
 
Browse Questions In:
AMC
Buick
Cadillac
Chevrolet
Chrysler
Dodge
Ford
Lincoln
Mercury
Oldsmobile
Packard
Plymouth
Pontiac
Studebaker
Volkswagen
Other Makes
Classic Trucks
 General Topics
General Questions
Help Identify
Classic Car News
General Restoration
Vehicle Maintenance
Site Suggestions & Comments













 
 


Ask a Question in OldRide Answers
 
Help Enrich the Classic Car Community
 
Explore Closed Questions and Answers
 Search Questions: 
 
alcauchon
    
None of my gages work on my dashboard I have a 1972 F 250 with a 360 engine
My gages stopped working one by one and then only worked intermittinly. I have take the instrument panel out and checked the circuit board and all the inline fuses as well as the fuses in the fuse block. They all checked out good. I cleaned everything and did a continuity test and it shows the circuit is good. All of my insturment panel lights and direcinals work. But none of my gages do. I have a wiring scchematic for the truck and checked all the lines for fuses etc and everything seems to be in good order.
Chiltons manual says when all the gages done't work it's a blown fuse. But I cant find one.

Can anyone give me any ideas what the problem might be. I also put a new low voltage regulator on the back ot the instrument panel which is used for the gages and this didn't do any good. I am sure it is something simple , but I can't find it.
By the way all the gages did not go out at once.
posted: October 27, 2008
 
    
 
  Answers (2)
 
nomadsrule
    
Are you sure you have a good ground?
posted:  October 27, 2008
Click to close this picture
   
 
fordsforever
    
I would also agree you have a ground issue. Make sure the motor is grounded to the frame and the dash has a good ground.
posted:  November 6, 2008
Click to close this picture
   
 
 

Home | Classifieds: Vehicles / Parts | Sell on OldRide | Rusty Rides | OldRide Answers | Events | Clubs

Library | Car & Truck Resources | MyOldRide Account | Support | OldRide Banners | Car Photos


Copyright © 2014 Internet Brands, Inc. All rights reserved | OldRide Support | Terms of Use | Classifieds Disclaimer | Privacy Policy | Cookies