Your Classic Car Community and Marketplace
MyOldRide Account | OldRide Store | Support | Site Map   
OldRide HomeClassic Cars and Trucks For SaleClassic Car and Truck Parts For SaleSell on OldRideOldRide AnswersRusty RidesCar Show ListingsCar Club ListingsResearch Library 
 
OldRide Answers Home
Using OldRide Answers
Ask a Question
 
Browse Questions In:
AMC
Buick
Cadillac
Chevrolet
Chrysler
Dodge
Ford
Lincoln
Mercury
Oldsmobile
Packard
Plymouth
Pontiac
Studebaker
Volkswagen
Other Makes
Classic Trucks
 General Topics
General Questions
Help Identify
Classic Car News
General Restoration
Vehicle Maintenance
Site Suggestions & Comments













 
 


Ask a Question in OldRide Answers
 
Help Enrich the Classic Car Community
 
Explore Closed Questions and Answers
 Search Questions: 
 
zeb2
    
Speedo cable to long but odometer works speedo stuck at 30 mph ..... what's up with that ???????
I just had my speepometer replaced. The one I used was 8-10 inches to long. The problem is that the odometer works fine but the speedometer is stuck on 30 mph reguaredless of how fast I go. It's been 2 weeks and still the same results. What did I do wrong ???HELP !!!!!
Al
posted: September 29, 2008
 
    
 
  Answers (0)
 
 

Home | Classifieds: Vehicles / Parts | Sell on OldRide | Rusty Rides | OldRide Answers | Events | Clubs

Library | Car & Truck Resources | MyOldRide Account | Support | OldRide Banners | Car Photos


Copyright © 2014 Internet Brands, Inc. All rights reserved | OldRide Support | Terms of Use | Classifieds Disclaimer | Privacy Policy | Cookies